13 сентября 2016

Критическая уязвимость в MySQL

Портал legalhackers.com опубликовал сведения о критической уязвимости (CVE-2016-6662) в MySQL, включая такие производные продукты, как MariaDB и Percona Server. Там же приводятся данные о том, как уязвимость может быть использована злоумышленниками.

Затрагиваемые версии MySQL:

  • <= 5.7.15
  • <= 5.6.33
  • <= 5.5.52

Уязвимость позволяет любому пользователю с правами на выполнение операций SELECT/FILE локально или удалённо атаковать сервер MySQL, повысив свои привилегии до root-пользователя. Причем права FILE требуются не обязательно, но способ обхода будет опубликована позднее под CVE-2016-6663.

Обновления пакетов с прошлыми версиями mysql/mariadb в дистрибутивах еще не выпущены (Ubuntu, Debian, RHEL, FreeBSD, CentOS, Fedora, SUSE). Применяемые по умолчанию правила SELinux и AppArmor не влияют на результаты атаки. Однако есть рекомендации по минимизации рисков: